[Dirvish] The FuhHoe post-server script

shouldbe q931 shouldbeq931 at gmail.com
Sat Jun 11 15:15:50 UTC 2011


On Fri, Jun 10, 2011 at 10:21 AM, Paul Slootman <paul at debian.org> wrote:
> On Fri 10 Jun 2011, shouldbe q931 wrote:
>>
>> 00:15:01 dirvish --vault vault1
>> /bin/sh: RAID/Share: No such file or directory
>> vault1:default post-server failed (127)
>> 02:00:50 dirvish --vault vault2
>>
>> followed by the output that I would expect from the script running
>> correctly for vault2 etc.
>
> Strange, perhaps the script is explicitly called with "sh script" which
> bypasses the #! line.
>
> Add a second line below the #! line containing:
> set -x
>
> Also check the files in the image directory, perhaps the output is
> redirected there instead of the mail output.
>
>
> Paul
> _______________________________________________

The top two lines are now

#!/bin/bash -x
set -x

The image directory doesn't appear to have anything "extra" in it

I tried just running dirvish-runall and got the following output

----------------------------------------------------------------
# dirvish-runall
15:23:50 dirvish --vault vault1
/bin/sh: RAID/Share: No such file or directory
vault1:default post-server failed (127)
15:35:07 dirvish --vault vault2
+ set -x
----------------------------------------------------------------

followed by the rest of the output as expected...

>From the last line above, I don't understand as to why I don't see it
as the 3rd line, to my (very) untrained mind, it's as if the "error"
happens before it gets to the first line of the dirvish_mail.sh
script.

I'm confused :-(


More information about the Dirvish mailing list