[Dirvish] Trouble creating directory names with special characters (rsync error)

Dave Howorth dhoworth at mrc-lmb.cam.ac.uk
Wed Feb 21 02:59:14 PST 2007


Yeray Gutiérrez Cedrés wrote:
> Before asking on the rsync list I've tried to run the rsync command
> that dirvish is supposed to run. Something like:
> 
> admin$ rsync -vrltH --delete -pgo --stats -z -D --numeric-ids
> yeray at remotehost:/home/yeray/ /Users/admin/rsynctest/

You can see in dirvish's log file exactly what rsync command it ran (if
that wasn't how you constructed this command)

> In the directory /home/yeray there were some directories and files
> which names had special characters and everything worked ok.
> 
> receiving file list ... done
> ./
> Gesti\#303\#263n/
> .bash_history
> .bash_logout
> .bash_profile
> .bashrc
> .viminfo
> Gesti\#303\#263n/administraci\#303\#263n.php
> 
> Number of files: 8
> Number of files transferred: 6
> 
> Isn't it funny?

Assuming you're running the same command that dirvish is, the difference
  is almost certainly due to some difference in the environment.
Presumably one of the locale settings. I'd guess that your user
environment is more localised than the root (?) environment that dirvish
is using.

But I know little enough about how locales work on my own Suse systems,
let alone Fedora Core release 3 and Mac OS X Server 10.4 :(

> By the way, thank you for your answers :)

Cheers, Dave


More information about the Dirvish mailing list