[Dirvish] broken pipe

Dave Howorth dhoworth at mrc-lmb.cam.ac.uk
Thu Sep 1 02:22:48 PDT 2005


Martin Ziegler wrote:
> After 
> 
> dirvish --vault client --init
> 
> I get the following error: dirvish error: branch /path-on-backup:default
> image 2005-08-30 failed with error 12 (broken pipe)
> 
> ./2005-08-30/log says: 
>   ACTION: rsync -vrltH --delete -pgo --stats -D --numeric-ids -x
> --rsync-path
>   ="/usr/local/bin/rsync-new" dirvish at client:/path-on-client/
> /path-on-backup/2005-08-30/tree
>   
>   broken pipe
>   RESULTS: warnings = 0, errors = 1
> 
>   ...
> 
> and ./2005-08-30/rsync_errors says
> 
>   *** Execution cycle 0 ***
> 
>   rsync: connection unexpectedly closed (0 bytes received so far) [receiver]
>   rsync error: error in rsync protocol data stream (code 12) at io.c(443)
>  
>   ...
> 
> Executing the above rsync command in a shell shows now problems. Client and
> server are running FreeBSD 5.4
> 
> Somebody any hints on this?

I can't suggest much but nobody else seems to have anything better, so ...

(1) If rsync works from the command line but not from the dirvish 
script, have you checked that the Linux user ids are the same, and that 
the rsync ids are the same?

(2) It's possible to repeat the -v option to rsync to get more information.

(3) There were apparently some problems with old rsyncs, so make sure 
you have a fairly recent one (can't remember details, sorry).

(4) You could try posting your config files to see if they jog 
somebody's memory.

Cheers, Dave



More information about the Dirvish mailing list