[Dirvish] help (with dirvish-runall)

Wei Li wei at eng.fsu.edu
Mon Feb 14 10:07:51 PST 2005


Thank you very much, Keith and Paul,

I installed dirvish in my Solaris 9 box 02/04 this year and got a 
seal-e122:default:2005-0204-1254: ERROR: no images for branch default 
found error message. Then I checked the mailing list archive and got the 
solution. Ran dirvish with --init parameter and it took me four days to 
init a 418GB file system to an disk array.

My master.conf file is as below:

seal:/etc/dirvish> more master.conf
bank:
       /backup/dirvish/seal
                exclude:
                        lost+found/
                        core
                        *~
                        .nfs*
                Runall:
                        seal-e121    22:00
                        seal-e122    23:00
                        seal-e125    0:00
                expire-default: never
                expire-rule:
                #       MIN HR    DOM MON       DOW  STRFTIME_FMT
                        *   *     *   *         *    +3 months
                        *   *     *   *         1    never
                pre-server: /usr/local/sbin/dirvish-pre
                post-server: /usr/local/sbin/dirvish-post
seal:/etc/dirvish>

The default.conf and default.hist as below:

[root at seal dirvish]# pwd
/backup/dirvish/seal/seal-e121/dirvish
[root at seal dirvish]# more default.hist
#IMAGE  CREATED REFERECE        EXPIRES
2005-0204-1136  2005-02-08 09:26:16     default Never
[root at seal dirvish]# more default.conf
client: seal
tree: /home/e121
xdev: true
index: gzip
image-default: %Y-%m%d-%H%M
exclude:
        /**/.*/**/*cache/
        /**/.*/*cache/
        /**/.*/**/*Cache/
        .kde/share/thumbnails/
[root at seal dirvish]#

Just now, when I tried to run dirvish --vault seal-e121, it gave me another no image found error.

Thanks



Keith Lofstrom wrote:

>On Mon, Feb 14, 2005 at 10:44:13AM -0500, Wei Li wrote:
>  
>
>>Hi, all,
>>
>>I have been following the article in System Admin and with dirvish 
>>--init --vault $VAULT, created the initial images.
>>After that, when I tried to run dirvish-runall, it gave me another no image error.[root at seal sbin]# ./dirvish-runall
>>10:40:05 done
>>but with nothing new created.
>>I have to re-run dirvish --init --vault command to recreate the image.
>>
>>I am using solaris 2.9.
>>    
>>
>
>Without more information, it is hard to guess what is happening,
>but my guess is that you don't have your banks or vaults listed
>in master.conf .
>
>Try decomposing the problem a bit.  After you create the vaults with
>  
>  dirvish --init --vault $VAULT
>
>you should try running dirvish again, on a single vault:
>
>  dirvish --vault $VAULT
>
>That will use master.conf, but it will ignore the Runall: field .
>To see what it did, look for another image in the vault, and look
>in the image for "log" and "summary".  
>
>After you prove you can do single vaults, make sure that all the
>vaults you want dirvish-runall to touch are listed in the "Runall:"
>section of master.conf, like so:
>
>...
>Runall:
>   vault1 03:00
>   vault2 03:00
>   vault3 03:00
>...
>
>Note that runall will label the images with the hour listed in the
>second column;  if you are experimenting and running dirvish-runall
>more than once per day you might want to leave the optional times off
>so dirvish doesn't try to write two images with the same time on them.
>
>Obviously, something got missed in the setup, and eventually you will
>find it.  That probably points to a documentation hole or bad explanation,
>so please share with us what you learn, and what mistaken impressions
>that your solution corrects.
>
>
>  
>


More information about the Dirvish mailing list